Appendix- C

Necessary Debug Information For

InterSKY® 3/5.x Devices
This document contains information proprietary to SpaceBridge and may not be reproduced in whole or in part without the express written consent of SpaceBridge. The disclosure by SpaceBridge of information contained herein does not constitute any license or authorization to use or disclose the information, ideas or concepts presented. The contents of this document are subject to change without prior notice.
# Table of Content

1. **INTRODUCTION** .................................................................................................................. 4
2. **HYPER TERMINAL** ........................................................................................................... 5
3. **GENERAL DETAILS** ....................................................................................................... 6
   3.1. **SWITCH DETAILS** .................................................................................................... 6
   3.2. **ROUTER DETAILS** .................................................................................................... 6
4. **INCIDENTS RELATED TO TERMINAL:** ......................................................................... 7
   4.1. **TERMINAL DETAILS** ............................................................................................ 7
   4.2. **FTP CONFIGURATION** ........................................................................................... 7
   4.3. **SAVING EVENT LOGGER AND ERROR LOGGER** .................................................. 10
   4.4. **NCC DATA BASE LOG FILES** .............................................................................. 12
5. **INCIDENTS RELATED TO MCD** .................................................................................... 13
   5.1. **MCD VERSION AND TYPE** .................................................................................. 13
   5.2. **MCD EVENT AND ERROR LOGS** .......................................................................... 14
6. **INCIDENTS RELATED TO NCC** ..................................................................................... 18
   6.1. **NCC VERSION** ....................................................................................................... 18
   6.2. **DATA BASE FILES** ............................................................................................... 18
   6.3. **NCC REGISTRY** ...................................................................................................... 19
   6.4. **NCC – EVENT LOGS** ............................................................................................. 20
   6.5. **TASK MANAGER** .................................................................................................... 23
7. **INCIDENTS RELATED TO MCDC** .................................................................................... 24
   7.1. **MCDC VERSION** ..................................................................................................... 24
   7.2. **DATA BASE FILES** ............................................................................................... 24
   7.3. **MCDC REGISTRY** .................................................................................................... 25
   7.4. **MCDC – EVENT LOGS** .......................................................................................... 26
   7.5. **TASK MANAGER** .................................................................................................... 27
8. **INCIDENTS RELATED TO ARU** ..................................................................................... 28
   8.1. **ARU VERSION** ........................................................................................................ 28
   8.2. **DATA BASE FILE** .................................................................................................. 28
   8.3. **ARU REGISTRY** ......................................................................................................... 29
   8.4. **ARU – EVENT LOGS** .............................................................................................. 30
   8.5. **TASK MANAGER** .................................................................................................... 31
9. **CHECK LIST** ................................................................................................................... 31
1. **Introduction**

This procedure will guide you on which information is requiring when you approach SPACEBRIDGE InterSKY customer support services. The procedure is divided in such manner, which allows us focus on specific Sub-system devices. It is design to improve Spacebridge service.

SPACEBRIDGE customer support team

[Supporshiron@asatnet.com](mailto:Supporshiron@asatnet.com)
[customerservices@spacebridge.com](mailto:customerservices@spacebridge.com)
2. **Hyper Terminal – using to connect the MCD, Terminal, Router and Switches**

2.1.1. Navigate to Start → All Programs → Accessories → Communications and Open HyperTerminal

2.1.2. Inside the Name field type: console and press ok

2.1.3. Choose your COM Port (In most cases it will be com1) and press OK.
2.1.4. In the COM Port Properties press on Restore Defaults and press OK

3. **General details**

3.1. **Switch Details** – log into the switch using HyperTerminal and run the following commands:

   3.1.1. show running-config

   3.1.2. show vlan

   3.1.3. Save all information on a text file (do it for both switches).

3.2. **Router Details** – log into the router using HyperTerminal and run the following command:

   3.2.1. show running-config

   3.2.2. Save all information on a text file.
4. **Incidents related to Terminal:**

4.1. **Terminal details**

4.1.1. Serial Number on the back of the IRG

4.1.2. Log into the IRG by means Hyper Terminal with default settings and copy - Terminal type, version, ID, PPC, MIPS, FW, HW (at the upper part of the screen), System Status and Operation Mode (at the lower part of the screen).

![Main Menu](image1)

4.2. **FTP configuration**

4.2.1. Connect IRG Ethernet port to PC by cross cable, and verify the connectivity by LED indication. Install Tornado – WFTPD software on PC, connected to the IRG LAN (you can download the FTP server installation file -

4.2.2. Start WFTPD

4.2.3. From the menu select Security → Users/rights.
4.2.4. On the User/Rights Security Dialog click on New User button.

4.2.5. Enter: iRG to User Name field and click OK.

4.2.6. Enter and verify the new password (rg) and click Ok.

4.2.7. In the User/Rights Security Dialog box, enter C:\iRG to the Home Directory field, (ensure that such a folder exists on your computer).

4.2.8. Click the Rights>> button, enter * to Directory field and click done.
4.2.9. From the main menu select Logging → Log Options.

4.2.10. Check all options except for Winsock Calls and click OK.

4.2.11. The following procedure assumes use of Tornado software. If another FTP server utility is in use, the following parameters must be used:

- Username: irg
- Password: rg
- Create folder C:\irg and define it as Home Directory.
4.3. Saving Event logger and Error logger:

4.3.1. Navigate to Status Display \(\rightarrow\) Logger Display from IRG main menu.
4.3.2. Enter "Save Event Log to File" and insert the IP address for the local PC under "Host IP Address" (the one that connected with a cross cable and have the FTP server installed).
4.3.3. Enter "Save Error Log to file" and insert the IP address for the local PC under "Host IP Address" (the one that connected with a cross cable and have the FTP server installed).

4.4. NCC Data Base log files

4.4.1. Navigate to C:\Program Files\Shiron\NCC\DB and copy following files to another directory:

- Exceptions.mdb
- Sky.mdb
- Nms.mdb
5. **Incidents related to MCD**

5.1. **MCD version and type.**
5.2. MCD Event and Error Logs (there are 2 options to retrieve the logs)

5.2.1. MCD is still connected to the Hub (pings from MCDC to MCD)

- Log into MCD using HyperTerminal

- Navigate to Status Display → Logger Display → Save Event Log to File/Save Error Log to File, insert Host IP Address (MCDC IP address) and press Enter. (All logs file will be save on MCDC server at C:\MCDC)
5.2.2. MCD is connected to a single PC with FTP server (LAN cable need to be connected to the control port on MCD).

- FTP server configuration
  - User Name: vx
  - Password: vx
- Log into MCD using HyperTerminal
- Navigate to Status Display → Logger Display → Save Event Log to File/Save Errors Log to File, insert Host IP Address (PC IP address) and press Enter.
6. Incidents related to NCC

6.1. NCC version

- Click on Help → About NCC, the version of the NCC will appear.

6.2. Data Base Files – Navigate to C:\Program Files\SHIRON\NCC\DB and Save:

- Exceptions.mdb
- Sky.mdb
- Nms.mdb
6.3. NCC registry

6.3.1. Navigate to Start → Run, type regedit.exe, click OK.

6.3.2. Open HKEY_LOCAL_MACHINE\SOFTWARE\INTERSKY
6.3.3. Export and Save Register

- Click on File, Export and save the file as shown below

![Image of Export and Save Register]

6.4. NCC – Event Logs

6.4.1. Press on Start → My Computer and right click on it (if "My Computer" icon is on the desktop simply right click on it) → Manage.

6.4.2. Computer Management will open, double click with the mouse on Event Viewer will open the necessary services.

6.4.3. Press on "Application" then right click and choose "Save Log File As..." , in the File Name field type application (make sure that the "Save as type" is *.evt) and press on "Save"

6.4.4. Press on "Security" then right click and choose "Save Log File As..." , in the File Name field type security (make sure that the "Save as type" is *.evt) and press on "Save"

6.4.5. Press on "System" then right click and choose "Save Log File As..." , in the File Name field type system (make sure that the "Save as type" is *.evt) and press on "Save"
### 6.5. NCC-1

<table>
<thead>
<tr>
<th>Test Procedure</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>1</strong> Make sure that the XP Service Pack is 3. Go to start\run in the command line enter “winver” in the prompted window you should see that service pack is 3.</td>
<td></td>
</tr>
<tr>
<td><strong>2</strong> Verify that IE6 is installed.</td>
<td></td>
</tr>
<tr>
<td><strong>3</strong> Make sure that the NCC version is 5.1. Go to the NCC application help\about.</td>
<td></td>
</tr>
<tr>
<td><strong>4</strong> Make sure that the NCC Application will be launched on startup. In order to do so right click on the start button. Select Open All Users, go to programs\startup. Make sure that the runexe.exe is present. Right click on it and select properties\shortcut. Make sure that the path of the run.exe and the pro.exe are correct set a time out of 8 seconds for the application to launch.</td>
<td></td>
</tr>
<tr>
<td><strong>5</strong> Make sure that the XP is set to auto restart in case of power failure. Go to Start\Settings\Control Panel\System\advanced select the Startup and recovery button. Make sure that the restart automatically option is checked.</td>
<td></td>
</tr>
<tr>
<td><strong>6</strong> Make sure that the XP is set to 3 seconds count at reboot. Go to Start\Settings\Control Panel\System\advanced select the Startup and recovery button. Make sure that show list parameter is set to 3 seconds.</td>
<td></td>
</tr>
<tr>
<td><strong>7</strong> Make sure that network Monitor is installed. Go to start\programs\Network Analysis Tools\network monitor.</td>
<td></td>
</tr>
<tr>
<td><strong>8</strong> Make sure to have a copy of the NCC users Data base, go to c:\program files\Shiron\NCC\DB\nms.mdb, Ragent.mdb</td>
<td></td>
</tr>
<tr>
<td><strong>9</strong> While applicable Make sure that RDP connection enable. It should be set with TCPIP option selected. Make sure that it is password secured and protected from properties changes.</td>
<td></td>
</tr>
<tr>
<td><strong>10</strong> Make sure that the NCC PC turns on after power failure. If not make the necessary changes in the BIOS. Enter the BIOS.</td>
<td></td>
</tr>
<tr>
<td><strong>11</strong> Make sure unnecessary accessories of the WinXP are not shown. Go to start\programs\accessories if EXE files with no content are shown, go to C:\WinNT\profiles\default user (Admin)\start menu\programs\accessories and delete these files from both locations.</td>
<td></td>
</tr>
<tr>
<td><strong>12</strong> Verify that the event viewer shows no errors under system events.</td>
<td></td>
</tr>
<tr>
<td><strong>13</strong> Make sure SNMP Agent launches automatically at startup</td>
<td></td>
</tr>
</tbody>
</table>
## 6.6. NCC-2

<table>
<thead>
<tr>
<th></th>
<th>Make sure that the XP Service Pack is 3. Go to start\run in the command line enter “winver” in the prompted window you should see that service pack is 3.</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>Verify that IE6 is installed.</td>
</tr>
<tr>
<td>3</td>
<td>Make sure that the NCC version is 5.1. Go to the NCC application help\about.</td>
</tr>
<tr>
<td>4</td>
<td>Make sure that the NCC Application will be launched on startup. In order to do so right click on the start button. Select Open All Users, go to programs\startup. Make sure that the runexe.exe is present. Right click on it and select properties\shortcut. Make sure that the path of the run.exe and the pro.exe are correct set a time out of 45 seconds for the application to launch.</td>
</tr>
<tr>
<td>5</td>
<td>Make sure that the XP is set to auto restart in case of power failure. Go to Start\Settings\Control Panel\System\advanced select the Startup and recovery button. Make sure that the restart automatically option is checked.</td>
</tr>
<tr>
<td>6</td>
<td>Make sure that the XP is set to 3 seconds count at reboot. Go to Start\Settings\Control Panel\System\advanced select the Startup and recovery button. Make sure that show list parameter is set to 3 seconds.</td>
</tr>
<tr>
<td>7</td>
<td>Make sure that network Monitor is installed. Go to start\programs\Network Analysis Tools\network monitor.</td>
</tr>
<tr>
<td>8</td>
<td>Make sure to have a copy of the NCC users Data base, go to c:\program files\Shiron\NCC\DB\nms.mdb,Ragent.mdb</td>
</tr>
<tr>
<td>9</td>
<td>While applicable Make sure that RDP connection enable. It should be set with TCPIP option selected. Make sure that it is password secured and protected from properties changes.</td>
</tr>
<tr>
<td>10</td>
<td>Make sure that the NCC PC turns on after power failure. If not make the necessary changes in the BIOS. Enter the BIOS.</td>
</tr>
<tr>
<td>11</td>
<td>Make sure unnecessary accessories of the WinXP are not shown. Go to start\programs\accessories if EXE files with no content are shown, go to C:\WinNT\profiles\default user (Admin)\start menu\programs\accessories and delete these files from both locations.</td>
</tr>
<tr>
<td>12</td>
<td>Verify that the event viewer shows no errors under system events.</td>
</tr>
<tr>
<td>13</td>
<td>Make sure SNMP Agent launches automatically at startup</td>
</tr>
</tbody>
</table>
6.7. Task Manager

- Navigate to View → Select Columns and Check all the relevant boxes as shown in the picture below and press OK.

- Navigate to Processes tab and sort it by double click on Mem Usage.

![Task Manager screenshot](image-url)
7. **Incidents related to MCDC**

7.1. **MCDC version**

- Click on Help → About NCC, the version of the MCDC will appear.

7.2. **Data Base Files**

7.2.1. Navigate to `C:\Program Files\SHIRON\MCDC\DB` and Save:

- Exceptions.mdb
- Logger.mdb
- mcd.mdb
7.3. MCDC registry

7.3.1. Navigate to Start ➔ Run, type regedit.exe and click OK.

7.3.2. Open HKEY_LOCAL_MACHINE\SOFTWARE\INTERSKY
7.3.3. Export and Save Register

- Click on File, Export and save the file as shown below

![Registry Editor](image)

7.4. MCDC – Event Logs

7.4.1. Press on Start → My Computer and right click on it (if "My Computer" icon is on the desktop simply right click on it) → Manage.

7.4.2. Computer Management will open, double click with the mouse on Event Viewer will open the necessary services.

7.4.3. Press on "Application" then right click and choose "Save Log File As..." , in the File Name field type application (make sure that the "Save as type" is *.evt) and press on "Save"

7.4.4. Press on "Security" then right click and choose "Save Log File As..." , in the File Name field type security (make sure that the "Save as type" is *.evt) and press on "Save"

7.4.5. Press on "System" then right click and choose "Save Log File As..." , in the File Name field type system (make sure that the "Save as type" is *.evt) and press on "Save"
7.5. Task Manager

- Navigate to View → Select Columns and Check all the relevant boxes as shown in the picture below and press OK.

- Navigate to Processes tab and sort it by double click on Mem Usage.
8. Incidents related to ARU

8.1. ARU version

- Click on Help → about NCC, the version of the MCDC will appear.

![Image of ARU version window]

8.2. Data Base File

8.2.1. Navigate to `C:\Program Files\SHIRON\ARU\DB` and Save:

- Exceptions.mdb
- Logger.mdb
8.3. ARU registry

8.3.1. Navigate to Start → Run, type regedit.exe and click OK.

8.3.2. Open HKEY_LOCAL_MACHINE\SOFTWARE\INTERSKY
8.3.3. Export and Save Register

- Click on File, Export and save the file as shown below

![Export Registry File]

8.4. ARU – Event Logs

8.4.1. Press on Start → My Computer and right click on it (if "My Computer" icon is on the desktop simply right click on it) → Manage.

8.4.2. Computer Management will open, double click with the mouse on Event Viewer will open the necessary services.

8.4.3. Press on "Application" then right click and choose "Save Log File As..." , in the File Name field type application (make sure that the "Save as type" is *.evt) and press on "Save"

8.4.4. Press on "Security" then right click and choose "Save Log File As..." , in the File Name field type security (make sure that the "Save as type" is *.evt) and press on "Save"

8.4.5. Press on "System" then right click and choose "Save Log File As..." , in the File Name field type system (make sure that the "Save as type" is *.evt) and press on "Save"
8.5. Task Manager

- Navigate to View → Select Columns and Check all the relevant boxes as shown in the picture below and press OK.

- Navigate to Processes tab and sort it by double click on Mem Usage.

9. Check List
<table>
<thead>
<tr>
<th>General Details</th>
<th>Upper Switch Configuration</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Lower Switch Configuration</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Router Configuration</td>
<td></td>
</tr>
<tr>
<td>Terminal Details</td>
<td>Terminal Serial number</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Terminal Version</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Terminal ID</td>
<td></td>
</tr>
<tr>
<td></td>
<td>PPC</td>
<td></td>
</tr>
<tr>
<td></td>
<td>MIPS</td>
<td></td>
</tr>
<tr>
<td></td>
<td>FW</td>
<td></td>
</tr>
<tr>
<td></td>
<td>HW</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Error Log</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Event Log</td>
<td></td>
</tr>
<tr>
<td>MCD Details</td>
<td>MCD version</td>
<td></td>
</tr>
<tr>
<td></td>
<td>MCD ID</td>
<td></td>
</tr>
<tr>
<td></td>
<td>MCD S/N</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Error Log</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Event Log</td>
<td></td>
</tr>
<tr>
<td>NCC Details</td>
<td>NCC version</td>
<td></td>
</tr>
<tr>
<td>NCC Data Base Log Files</td>
<td>Exceptions.mdb</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Sky.mdb</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Nms.mdb</td>
<td></td>
</tr>
<tr>
<td></td>
<td>NCC Registry</td>
<td></td>
</tr>
<tr>
<td></td>
<td>NCC Task Manager</td>
<td></td>
</tr>
<tr>
<td>MCDC Details</td>
<td>MCDC Version</td>
<td></td>
</tr>
<tr>
<td>MCDC Data Base Log Files</td>
<td>Exceptions.mdb</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Logger.mdb</td>
<td></td>
</tr>
<tr>
<td></td>
<td>mcd.mdb</td>
<td></td>
</tr>
<tr>
<td></td>
<td>MCDC Registry</td>
<td></td>
</tr>
<tr>
<td></td>
<td>MCDC Task Manager</td>
<td></td>
</tr>
<tr>
<td>ARU Details</td>
<td>ARU Version</td>
<td></td>
</tr>
<tr>
<td>ARU Data Base Log Files</td>
<td>Exceptions.mdb</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Logger.mdb</td>
<td></td>
</tr>
<tr>
<td></td>
<td>ARU Registry</td>
<td></td>
</tr>
<tr>
<td></td>
<td>ARU Task Manager</td>
<td></td>
</tr>
</tbody>
</table>

**Note:**
Please fill the relevant details regarding the incident and send it by E-mail to
All Data/Configuration files can be uploaded to Spacebridge FTP server or can be sent to SPACEBRIDGE support Email address.